Gentoo MythTV

27. 08. 08

if i only knew this many hours ago…

Filed under: configuration — Tags: , , — niko86 @ 15:15

there is an overlay for portage which includes all the openchrome patches to make xvmc work with mplayer.
you can find an article about it here: click
i will report about how this works out after the re-emerging has finished.

update:
I did not do much yesterday, just came back home and evaluated the situation.
what i can say right now is that you should re-emerge every xorg module you got.
currently the X-Server is not able to start because of some x264 library which i did not recompile.
Since i got some kind of “failsafe” setup which makes X restart in case of a failure of X Server or mythfrontend, the system currently tries to restart X Server over and over again…
i will report on this later.
i will also wite a quick how-to about making X restart after a failure of mythfrontend.

second update
this is important to know:
since the article above suggests using ACCEPT_KEYWORDS=”~x86″ to install the ebuilds from the overlay (you might as well add the ebuild to /etc/portage/package.keywords), portage will pull in all ebuilds masked with the ~x86 keywords that are more up-to-date than the one installed right now.
this means that if there is a newer ebuild in the official portage tree masked with ~x86 than in the openchrome overlay you will end up installing a new masked ebuild which is not from the openchrome overlay.
to avoid this you should look in your openchrome overlay dir for the newest ebuild available and mask all newer ebuilds.
in my case i had to mask:
>media-video/mplayer-1.0_rc2_p26258
in /etc/portage/package.mask because this version is the newest in the openchrome overlay.

Advertisements

Blog at WordPress.com.